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Important Safety Notices 
1. Read all safety notices and operating instructions before operating this unit. 

2. Inspect the item for transport damage before using the 24VDC power supply for the first time. 

3. Adhere to all warning stickers on the unit and all warnings contained in this manual. 

Warranty 
Mikropack GmbH warrants to the original user of this instrument that it shall be free of any defects 
resulting from faulty manufacture of this instrument for a period of 12 months from the original data of 
shipment.  

This instrument should not be used for any Clinical or Diagnostic purposes. Data generated in these 
areas is not warranted in any way by Mikropack GmbH. Any defects covered by this Warranty shall be 
corrected either by repair or by replacement, as determined by Mikropack GmbH. 

There are no warranties that extend beyond the description herein.  

This Warranty is in lieu of, and excludes, any and all other warranties or representations expressed, 
implied, or statutory, including merchantability and fitness, as well as any and all other obligations or 
liabilities of Mikropack GmbH including, but not limited to, special or consequential damages. No 
person, firm, or corporation is authorized to assume for Mikropack GmbH. Any additional obligation or 
liability not expressed provided for herein except in writing duly executed by an officer of Mikropack 
GmbH: 

MIKROPACK GmbH 
Maybachstraße 11 
D-73760 Ostfildern 
 
Tel.: +49 (0)711 3428088 • Fax.: +49 (0)711 3428085 
e-mail: info@mikropack.de

 

Warranty Handling 

► Procedure 

Follow the procedure below to process a warranty claim: 

1. Determine the problem or fault with your local distributor. 

2. If a problem is evident, obtain an RMA number from your local distributor. 
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Important Safety Notices  

3. Send the equipment to the local distributor for repair. If the item is under warranty, shipping will 
be free-of-charge both ways. 

4. Contact your distributor for repair and delivery time. If the item is out of warranty, your 
distributor will provide a repair cost to you. In this situation, the distributor will not proceed with 
the repair until you order it. 

Your system will be shipped back to you free of charge with insurance (if under warranty). 
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About This Manual  

Document Purpose and Intended Audience 
This document provides you with an installation section to get your system up and running.  

What’s New in this Document 
This version of the Optical Multiplexer MPM-2000 Installation and Operation Manual adds our 
partnership agreement. 

Document Summary 
Chapter Description 

Chapter 1: Setup Contains a list of package contents and unpacking 
instructions. 

Chapter 2: MPM-2000 Specifications Contains operating environment specifications, as 
well as other physical details of the product. 

Chapter 3: Operating Instructions Provides instructions for operating Windows-based 
software that comes with the MPM-2000. 

 

Product-Related Documentation 
You can access documentation for Ocean Optics products by visiting our website at 
http://www.oceanoptics.com. Select Technical → Operating Instructions, then choose the appropriate 
document from the available drop-down lists. Or, use the Search by Model Number field at the bottom 
of the web page.  

You can also access operating instructions for Ocean Optics products on the Software and Technical 
Resources CD included with the system.  

Engineering-level documentation is located on our website at Technical → Engineering Docs. 

Upgrades 
Occasionally, you may find that you need Ocean Optics to make a change or an upgrade to your system. 
To facilitate these changes, you must first contact Customer Support and obtain a Return Merchandise 
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About This Manual  

Authorization (RMA) number. Please contact an Ocean Optics Application Scientist for specific 
instructions when returning a product. 
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Chapter 1  

Setup 

Overview 
The MPM-2000 Fiber Optic Multiplexer is a compact instrument that can optically couple one input 
channel to 16 different output channels. The MPM-2000 consists of a precisely controlled DC-motor with 
encoder and end switch on a rotator block. The optical path couples via UV collimating lenses.  

The Multiplexer features a CNC controller working in positioning mode, which eliminates step loss. The 
MPM-2000 is software controlled and interfaces to a PC through the RS-232 protocol. It automatically 
saves all calibrated positions in the memory of the controlling unit, and easy-to-use software facilitates 
calibration. The software enables full control of the switching order and delay time.  

The MPM-2000 is ideal for applications in process industry, where you need to measure multiple 
locations with multiple probes but with a single spectrometer channel and/or light source. The MPM-2000 
operates as a stand-alone unit and includes a sample program to guide you in setting up your application. 
The CD contains a driver for Windows, and you can configure the MPM-2000 in Ocean Optics 
OOIbase32 Platinum software. 

The following sections provide instructions on unpacking and setting up your MPM-2000 Optical 
Multiplexer. 
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1: Setup  

Unpacking the MPM-2000 
► Procedure 

1. Unpack the Optical Multiplexer carefully. Dropping this instrument can cause permanent 
damage. 

2. Inspect the outside of the instrument and make sure that there is no damage. Do not use the 
instrument if damage is present. Contact your dealer for repair or replacement information, if 
necessary. 

3. Use this instrument in a clean laboratory environment. 

4. Submit the Registration Card to for warranty and support purposes. 

Contents 
Your MPM-2000 Optical Multiplexer package should contain the following: 

• MPM-2000 Main System 

• MPM-2000 24VDC Power Supply 

Caution 

Before using the power supply of the MPM-2000 for the first time, inspect the item for 
transport damage. Be sure to adhere to all warnings on the unit and in this operational 
manual. 

• Software CD (contains MPM-2000 software and Calibration software) 

• PC-MPM-2000 Serial Cable  
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 1: Setup 

Typical System Configuration 
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Chapter 2  

MPM-2000 Specifications 

This section provides information on the operating environment and physical controls of the MPM-2000.  

Operating Environment 
The following table provides information on optimizing the operating environment of your MPM-2000. 

 

Operating Environment The MPM-2000 Unit . . . 

Moisture Is designed for operation in dry rooms only. 

Ventilation Should be situated so that its location or position does not interfere 
with proper ventilation. 

Heat Should be situated away from any device that emits excessive heat. 

Object and Liquid Entry Should be positioned so that objects do not fall on top of the unit. 
Additionally, ensure that no liquids are spilled into the enclosure 
through openings. 

Power Sources The unit should be connected to a power supply only of the type 
described in the operating instructions or as marked on the unit.  
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2: MPM-2000 Specifications  

MPM-2000 Components 
The following sections describe the components located on the front and rear of the MPM-2000 unit. 

Front Panel 

 

 
 

Note 

The front panel of both the 1 x 16 and 2 x 8 versions of th
Only the rear panel will differ (two inputs on the 2 x 8 ve

Power LED

6 
Error LED
e MPM-2000 are identic
rsion). 

000-
SMA 905 
Connectors
al. 
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 2: MPM-2000 Specifications 

Rear Panel 

 

24 VDC Power Input 

RS232 Port 
Connection 
(connects to PC)

Type Sign 

SMA 905 
Connector 
(connects to 
spectrometer) 
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2: MPM-2000 Specifications  
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Chapter 3 

Operating Instructions 

Operating Software 
The MPM-2000 comes with easy-to-use Windows-based software that allows you to control the MPM-
2000 Optical Multiplexer manually or create sequence programs (scripts) with preconfigured channel 
settings and delay times. The graphical software interface allows you to choose from three modes of 
operation: 

• Channel Mode 

• Program Mode 

• Small Mode 
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3: Operating Instructions  

Channel Mode 

 

 

Channel Mode allows you to change the active channel on the MPM-2000. You can click on any of the 
blue buttons associated with the SMA 905 Connectors on the front of the MPM-2000 to activate that 
channel. 

Once you activate a channel, the button for that channel turns red until you activate another channel. 
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 3: Operating Instructions 

Program Mode 

 

Program Mode allows you to create or change sequence programs used by the MPM-2000. The Program 
Mode interface contains the following items: 

 

Item Description 

Step Column Identifies the individual step number in the sequence program 

Channel Identifies the channel that the MPM-2000 will switch to in this step  

Time to wait Identifies the delay time before the MPM-2000 proceeds to the next step 

Time unit Defines the unit of time for the Time to wait column 

Continuous When checked, instructs the software to run the sequence program a 
specified number of times (specified in the no of runs box) 

No of runs 
Specifies the number of times the software will execute the sequence program 
(a value of –1 instructs the software to run the program until manually 
stopped) 
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3: Operating Instructions  

Small Mode 

 

Small Mode provides all functionality of the software in a condensed menu bar. When using another 
software package, the Always on Top feature of Small Mode eliminates the need to consistently switch 
back and forth between applications. This mode is only accessible via the View Menu. 

The Small Mode screen contains the following options: 

 

Item Function 

 Load an existing program sequence 

 Activate the loaded program sequence 

 Stop the currently running program sequence 

 Enable continuous mode  

 
Specifies the number of times the program sequence will execute (if continuous mode 
is active) 

 Increase the active channel on the MPM-2000 by one (+ 1 channel) 

 Decrease the active channel on the MPM-2000 by one (- 1 channel) 

 Specify a channel on the MPM-2000 

 Switch to the channel specified in the text box to the left of this button 

 Exit Small Mode and return to Channel Mode 
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 3: Operating Instructions 

Main Toolbar 
The Main Toolbar is only visible in Channel Mode and Program Mode. It contains the following buttons 
and features: 

Button Function 

 Switch to Channel Mode 

 Switch to Program Mode 

 Open new program sequence 

 Open an existing program sequence 

 Save the current program sequence 

 Start the currently loaded program sequence 

 Stop the currently running program sequence 

Menu Options 
The MPM-2000 software menu bar has four options: 

• File Menu 

• View Menu 

• Tools Menu 

• ? (help) 
The sections that follow detail each of these options. 

File Menu 
The File Menu contains the following options: 

Menu Option Description 

New Clear the program grid and open a new program sequence 

Open Open an existing program sequence 

Save Save the program sequence that you are currently editing 

Save As Save the program sequence that you are currently editing with a new filename 

Options Opens the Options dialog box 

Exit Exits the MPM-2000 software 
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3: Operating Instructions  

View Menu 
The View Menu allows you to toggle between the three different application modes. You can only access 
Small Mode using this option. 

Tools Menu 
The Tools Menu contains the following options: 

Menu Option Description 

Connect Connects to the MPM-2000 

Disconnect Disconnects from the MPM-2000 

Options Opens the Options dialog box 

Options Dialog Box 
The Options dialog box is accessible from the File Menu or Tools Menu. It contains the following two 
tabs: 

• Comport Tab 

• Settings Tab 

Comport Tab 

 

Select the COM port on the PC that you will use to communicate to the MPM-2000, and then click the 
OK button. 

You must ensure that this option is correct before the MPM-2000 will communicate with the PC. 
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 3: Operating Instructions 

Settings Tab 

 

Click the Always On Top check box to position the software window above any other running 
applications, and then click the OK button to save your changes. 

To specify the default mode that the MPM-2000 software will enter upon startup, select one of the three 
radio button options under the Startup View section of the Settings tab, and then click the OK button. 

Calibrating the MPM-2000 

Caution 

Do not execute this software unless MPM-2000 calibration is required. If used when not 
needed, this software can alter the correct settings of the MPM-2000 and require you to 
service or re-calibrate the unit. 

The MPM-2000 comes with software that allows you to calibrate the unit to ensure proper operation. 
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3: Operating Instructions  

To launch the calibration software, you must execute the MPM-2000-Calibration.exe file from a 
command line or the Start | Run option from the Windows toolbar.  

The MPM-2000-Calibration software contains the following options: 

Option Description 

 Displays the serial number of the multiplexer 

 Displays the Version of the MPM-2000-Calibration software 

 
Specifies the active channel number. Select a different channel 
from the drop-down menu to switch to that channel 

 
Displays the intensity of light (when used with an Ocean Optics 
spectrometer) 

            

Change the sampled wavelength position for the chosen channel. 
Each button represents large (<<< >>>), medium (<< >>), and 
small steps (< >), respectively. 

 Saves the actual multiplexer position in the software 

 
Writes the saved multiplexer positions to the memory of the MPM-
2000 

 Exits the program (saved values will be lost unless saved) 

MPM-2000-Calibration Options Menu 
The Options Menu contains the following items: 

 

Option Description 

Use with OOI Spectrometer Check this box if you want to use an Ocean Optics spectrometer 
for the calibration process 

Spectrometer Settings Select the type of spectrometer (if using an Ocean Optics 
spectrometer) 

Acquisition Parameter Change the acquisition parameters (if using an Ocean Optics 
spectrometer) 

COMport Select the COM port on which the MPM-2000 will communicate 
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 3: Operating Instructions 

Acquisition Parameter Options 
Select the Acquisition Parameter option from the Options menu to view the Acquisition Parameters 
Options dialog box: 

 

Option Description 

Integration time: Sets the integration time in OOIBase32 (when using an Ocean 
Optics spectrometer) 

Boxcar width: Sets the boxcar width in OOIBase32 (when using an Ocean 
Optics spectrometer) 

Averages: Specifies the number of scans that OOIBase32 will average (when 
using an Ocean Optics spectrometer) 

Pixel no.: Specifies the pixel number to sample (when using an Ocean 
Optics spectrometer) 

Master Applies the displayed options to the Master spectrometer channel 
(when selected) 

Slave 1 Applies the displayed options to the Slave 1 spectrometer channel 
(when selected and available) 

Slave 2 Applies the displayed options to the Slave 2 spectrometer channel 
(when selected and available) 

Slave 3 Applies the displayed options to the Slave 3 spectrometer channel 
(when selected and available) 

 

When using an Ocean Optics spectrometer, you can enter the acquisition parameters directly into this 
dialog box. Click the OK button when you have set the parameters you wish to use for your experiment. 
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3: Operating Instructions  

Comport Options 
Select the Comport option from the Options menu to view the Comport Options dialog box: 

 

Select the COM port you wish to use from the drop-down menu, and then click the OK button to enable 
the COM port change. 

Performing Calibration 

► Procedure 

Follow the steps below to perform a calibration on the MPM-2000: 

1. Establish the connection between the MPM-2000 and the PC, ensuring that the MPM-2000 is 
connected to the power supply. 

Note: 

Go to Step 5 if you are not using an Ocean Optics spectrometer 

2. Open the MPM-2000-Calibration software. 

3. Open the Options Menu and check the Use with OOI Spectrometer option. 

4. Select the correct spectrometer and A/D Converter from the Select Spectrometer option. 

5. Tweak the acquisition parameters to your environment, ensuring that the spectrometer is not 
saturated. 

6. Activate Channel 1 on the MPM-2000. 

7. Optimize the transmission by modifying the position of the multiplexer until the best transmission 
is obtained. 

8. Save the position for Channel 1 in the software. 

9. Activate the next channel, if needed.  Otherwise, proceed to Step 11. 

10. Repeat Steps 5-8 until all desired channels are optimized. 
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 3: Operating Instructions 

11. Click the Write to MPM button to save the data to the multiplexer. After writing the data to the 
MPM-2000, the calibration completes. 

12. Close the program with Exit command from the Options menu. 

MPM-2000.drv 
The MPM-2000.DRV is an interface DLL for use with Visual Basic or C/C++. It allows you to integrate 
the MPM-2000 in your own custom application.  

The MPM-2000.DRV package contains a sample program written in Visual Basic® and a sample 
program written in Visual C++®. 

For further details on how to use the MPM-2000.drv, consult the online documentation included with the 
MPM-2000.DRV. 
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